<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<title>St. Peters-based Stella’s Wish Foundation | Community News</title>

<!-- This site is optimized with the Yoast SEO plugin v11.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://mycnews.com/st-peters-based-stellas-wish-foundation/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="St. Peters-based Stella’s Wish Foundation - Community News" />
<meta property="og:description" content="Granting wishes St. Peters-based Stella’s Wish Foundation helps make wishes come true for terminally ill cancer patients By Brett Auten Shelly Barr will never forget it. Barr&#8217;s close friend, Lisa Drummond has Stage 4 Metastatic Colorectal Cancer. Drummond lost her middle son in 2016 and he left behind two sons, the eldest of which lives&hellip;" />
<meta property="og:url" content="https://mycnews.com/st-peters-based-stellas-wish-foundation/" />
<meta property="og:site_name" content="Community News" />
<meta property="article:publisher" content="http://www.facebook.com/mycews" />
<meta property="article:section" content="news" />
<meta property="article:published_time" content="2019-05-01T15:05:06+00:00" />
<meta property="article:modified_time" content="2019-05-01T15:05:19+00:00" />
<meta property="og:updated_time" content="2019-05-01T15:05:19+00:00" />
<meta property="og:image" content="https://mycnews.com/wp-content/uploads/2019/05/Cover-Wish-1024x951.jpg" />
<meta property="og:image:secure_url" content="https://mycnews.com/wp-content/uploads/2019/05/Cover-Wish-1024x951.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="951" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Granting wishes St. Peters-based Stella’s Wish Foundation helps make wishes come true for terminally ill cancer patients By Brett Auten Shelly Barr will never forget it. Barr&#8217;s close friend, Lisa Drummond has Stage 4 Metastatic Colorectal Cancer. Drummond lost her middle son in 2016 and he left behind two sons, the eldest of which lives&hellip;" />
<meta name="twitter:title" content="St. Peters-based Stella’s Wish Foundation - Community News" />
<meta name="twitter:site" content="@mycnews" />
<meta name="twitter:image" content="https://mycnews.com/wp-content/uploads/2019/05/Cover-Wish.jpg" />
<meta name="twitter:creator" content="@mycnews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mycnews.com/#organization","name":"","url":"https://mycnews.com/","sameAs":["http://www.facebook.com/mycews","https://twitter.com/mycnews"]},{"@type":"WebSite","@id":"https://mycnews.com/#website","url":"https://mycnews.com/","name":"Community News","publisher":{"@id":"https://mycnews.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://mycnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#webpage","url":"https://mycnews.com/st-peters-based-stellas-wish-foundation/","inLanguage":"en-US","name":"St. Peters-based Stella\u2019s Wish Foundation - Community News","isPartOf":{"@id":"https://mycnews.com/#website"},"image":{"@type":"ImageObject","@id":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#primaryimage","url":"https://mycnews.com/wp-content/uploads/2019/05/Cover-Wish.jpg","width":2048,"height":1902},"primaryImageOfPage":{"@id":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#primaryimage"},"datePublished":"2019-05-01T15:05:06+00:00","dateModified":"2019-05-01T15:05:19+00:00"},{"@type":"Article","@id":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#article","isPartOf":{"@id":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#webpage"},"author":{"@id":"https://mycnews.com/author/communitynews/#author","name":"Community News"},"publisher":{"@id":"https://mycnews.com/#organization"},"headline":"St. Peters-based Stella\u2019s Wish Foundation","datePublished":"2019-05-01T15:05:06+00:00","dateModified":"2019-05-01T15:05:19+00:00","commentCount":0,"mainEntityOfPage":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#webpage","image":{"@id":"https://mycnews.com/st-peters-based-stellas-wish-foundation/#primaryimage"},"articleSection":"news"},{"@type":"Person","@id":"https://mycnews.com/author/communitynews/#author","name":"Community News","image":{"@type":"ImageObject","@id":"https://mycnews.com/#personlogo","url":"https://secure.gravatar.com/avatar/f840dc139a2e76ee4361a9ef2facf93c?s=96&d=mm&r=g","caption":"Community News"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//746363.smushcdn.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Community News &raquo; Feed" href="https://mycnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Community News &raquo; Comments Feed" href="https://mycnews.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.6.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.6.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-76762812-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-76762812-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
<link rel='stylesheet' id='wp-block-library-css'  href='https://mycnews.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://mycnews.com/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://mycnews.com/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://mycnews.com/wp-content/themes/bb-theme/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://mycnews.com/wp-content/uploads/bb-theme/skin-5cd463b8b3e7c.css' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-6fd2b081dbaa3bb8686313de37b24bdf-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700&#038;ver=5.2' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/mycnews.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mycnews.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<script type='text/javascript' src='https://mycnews.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-includes/js/imagesloaded.min.js'></script>
<link rel='https://api.w.org/' href='https://mycnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mycnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mycnews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2" />
<link rel='shortlink' href='https://mycnews.com/?p=2574' />
<link rel="alternate" type="application/json+oembed" href="https://mycnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmycnews.com%2Fst-peters-based-stellas-wish-foundation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mycnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmycnews.com%2Fst-peters-based-stellas-wish-foundation%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":2574,"post_name":"st-peters-based-stellas-wish-foundation","post_title":"St. Peters-based Stella\u2019s Wish Foundation","post_type":"post","post_author":"3","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":4,"name":"news","slug":"news","term_group":0,"term_taxonomy_id":4,"taxonomy":"category","description":"","parent":0,"count":255,"filter":"raw","cat_ID":4,"category_count":255,"category_description":"","cat_name":"news","category_nicename":"news","category_parent":0}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"Community News","ID":3};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="cc_mm" data-mailmunch-site-id="306053" async></script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1258691894234538'); 
fbq('track', 'PageView');
</script>
<noscript>
<img height="1" width="1" 
src="https://www.facebook.com/tr?id=1258691894234538&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->
<!-- SEO meta tags powered by SmartCrawl https://premium.wpmudev.org/project/smartcrawl-wordpress-seo/ -->
<link rel="canonical" href="https://mycnews.com/st-peters-based-stellas-wish-foundation/" />
<meta name="description" content="Granting wishes St. Peters-based Stella’s Wish Foundation helps make wishes come true for terminally ill cancer patients By Brett Auten Shelly Barr will never forget it. Barr&#039;s close friend, Lisa Drummond has Stage 4 Metastatic Colorectal Cancer. Drummond lost her middle son in 2016 and he  ..." />
<script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"WebSite","about":"Community News","dateModified":"2019-05-08 17:10:39.000000","description":"Community News","encoding":"UTF-8","headline":"Community News","inLanguage":"en-US","name":"Community News","publisher":{"@type":"Organization","name":"Community News"},"url":"https:\/\/mycnews.com"},{"@context":"http:\/\/schema.org","@type":"Article","author":{"@type":"Person","name":"Community News","url":"https:\/\/mycnews.com\/author\/communitynews\/"},"commentCount":"0","dateModified":"2019-05-01T15:05:19","datePublished":"2019-05-01T15:05:06","description":"Granting wishes St. Peters-based Stella\u2019s Wish Foundation helps make wishes come true for terminally ill cancer patients By Brett Auten Shelly Barr will never forget it. Barr&#039;s close friend, Lisa Drummond has Stage 4 Metastatic Colorectal Cancer. Drummond lost her middle son in 2016 and he  ...","headline":"St. Peters-based Stella\u2019s Wish Foundation | Community News","image":{"@context":"http:\/\/schema.org","@type":"ImageObject","height":650,"url":"https:\/\/mycnews.com\/wp-content\/uploads\/2019\/05\/Cover-Wish.jpg","width":700},"mainEntityOfPage":"https:\/\/mycnews.com\/st-peters-based-stellas-wish-foundation\/","name":"St. Peters-based Stella\u2019s Wish Foundation","publisher":{"@type":"Organization","name":"Community News","logo":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/?s=96&d=mm&r=g","height":60,"width":60}},"thumbnailUrl":"https:\/\/mycnews.com\/wp-content\/uploads\/2019\/05\/Cover-Wish.jpg","url":"https:\/\/mycnews.com\/st-peters-based-stellas-wish-foundation\/"}]</script>
<!-- /SEO -->
		<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
				<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="stylesheet" href="https://mycnews.com/wp-content/themes/bb-theme-child/style.css" /></head>
<body data-rsssl=1 class="post-template-default single single-post postid-2574 single-format-standard fl-framework-bootstrap fl-preset-stripe fl-fixed-width has-blocks" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page">
	<header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-sm-6 col-md-6 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://mycnews.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://746363.smushcdn.com/1289476/wp-content/uploads/2015/08/Community-News-Logo.png?lossy=1&strip=1&webp=1" data-retina="" alt="Community News" /><meta itemprop="name" content="Community News" /></a>
											</div>
				</div>
				<div class="col-sm-6 col-md-6">
					<div class="fl-page-header-content">
						<div class="fl-page-header-text">Contact Us! (636) 379-1775

<p><!-- BEGIN: Constant Contact Email List Form Button --><div align="right"><a href="http://visitor.r20.constantcontact.com/d.jsp?llr=z8wyi7oab&p=oi&m=1115492735865&sit=kv9rvhiib&f=f048765c-89da-4ae2-a6ae-b79457ba6135" class="button" style="background-color: rgb(0, 26, 129); border: 1px solid rgb(91, 91, 91); color: rgb(255, 255, 255); display: inline-block; padding: 8px 10px; text-shadow: none; border-radius: 20px;">Subscribe </a></P></div>	<div class="fl-social-icons">
	<a href="https://www.facebook.com/mycnews" class="fa-stack icon-facebook-f" target="_blank"><span class="sr-only">Facebook</span>
					<i class="fas fa-circle fa-stack-2x branded"></i>
					<i class="fab fa-facebook-f branded fa-stack-1x fa-inverse"></i>
					</a><a href="https://twitter.com/mycnews" class="fa-stack icon-twitter" target="_blank"><span class="sr-only">Twitter</span>
					<i class="fas fa-circle fa-stack-2x branded"></i>
					<i class="fab fa-twitter branded fa-stack-1x fa-inverse"></i>
					</a><a href="https://www.pinterest.com/mycnews/" class="fa-stack icon-pinterest" target="_blank"><span class="sr-only">Pinterest</span>
					<i class="fas fa-circle fa-stack-2x branded"></i>
					<i class="fab fa-pinterest branded fa-stack-1x fa-inverse"></i>
					</a></div>
					</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav navbar navbar-default navbar-expand-md" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
				<button type="button" class="navbar-toggle navbar-toggler" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span>Menu</span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-18 nav-item"><a href="https://mycnews.com/" class="nav-link">HOME</a></li>
<li id="menu-item-2598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2598 nav-item"><a href="https://mycnews.com/best-of-st-charles-county/" class="nav-link">BEST OF ST. CHARLES COUNTY</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32 nav-item"><a href="https://mycnews.com/about-us/" class="nav-link">ABOUT US</a></li>
<li id="menu-item-671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-671 nav-item"><a href="https://mycnews.com/advertising/" class="nav-link">ADVERTISING</a></li>
<li id="menu-item-508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-508 nav-item"><a href="https://mycnews.com/blog/" class="nav-link">FEATURED STORIES</a></li>
<li id="menu-item-2327" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2327 nav-item"><a href="https://mycnews.com/gallery/" class="nav-link">GALLERY</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21 nav-item"><a href="https://mycnews.com/contact-us/" class="nav-link">CONTACT US</a></li>
</ul>				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div class="fl-page-content" itemprop="mainContentOfPage">

		
<div class="container">
	<div class="row">

		
		<div class="fl-content fl-content-left col-md-8">
			<article class="fl-post post-2574 post type-post status-publish format-standard has-post-thumbnail hentry category-news" id="fl-post-2574" itemscope itemtype="https://schema.org/BlogPosting">

	
	<header class="fl-post-header">
		<h1 class="fl-post-title" itemprop="headline">
			St. Peters-based Stella’s Wish Foundation					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://mycnews.com/author/communitynews/"><span>Community News</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date">May 1, 2019</span></div><meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://mycnews.com/st-peters-based-stellas-wish-foundation/" content="St. Peters-based Stella’s Wish Foundation" /><meta itemprop="datePublished" content="2019-05-01" /><meta itemprop="dateModified" content="2019-05-01" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Community News"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mycnews.com/wp-content/uploads/2015/08/Community-News-Logo.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://mycnews.com/author/communitynews/" /><meta itemprop="name" content="Community News" /></div><div itemscope itemprop="image" itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mycnews.com/wp-content/uploads/2019/05/Cover-Wish.jpg" /><meta itemprop="width" content="2048" /><meta itemprop="height" content="1902" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

	
	
	<div class="fl-post-content clearfix" itemprop="text">
		<div class='mailmunch-forms-before-post' style='display: none !important;'></div>
<p>Granting wishes</p>



<p>St. Peters-based Stella’s Wish Foundation helps make wishes come true for terminally ill cancer patients</p>



<p>By Brett Auten</p>



<p>Shelly Barr will never forget it.</p>



<p>Barr&#8217;s close friend, Lisa Drummond has Stage 4 Metastatic Colorectal Cancer. Drummond lost her middle son in 2016 and he left behind two sons, the eldest of which lives in Las Vegas. Drummond yearned to see her grandson once again, as the last time they met was it her son&#8217;s – and his dad&#8217;s – funeral.</p>



<p>“She did not want to be remembered as some grief-stricken woman,” Barr said.</p>



<p>That&#8217;s where Stella&#8217;s Wish Foundation stepped in and calmly said, “We got this.”</p>



<p>Just last month, flights were booked, Blue Man Group tickets were purchased and Barr was right by her friend&#8217;s side as Drummond reconnected with her grandson.</p>



<p>“The whole thing was heart melting,” Barr said. “It was nothing short of amazing. It was a whirlwind that we were not expecting to come to fruition. And Lisa made it through by sheer determination and will.”</p>



<p>Stella’s Wish Foundation is a St. Peters-based nonprofit foundation fully funded by sponsors, donors and fundraisers. It began granting wishes in Missouri, but soon branched to grant wishes across the United States. Since February 2008 Stella’s Wish Foundation has been searching to grant wishes and to collect charitable donations which are used to grant wishes for terminally ill cancer patients, ages 18-and-above.&nbsp;&nbsp;</p>



<p>Wishes that have been granted thus far range from a catered family gathering to Alaskan cruises with loved ones. There has been the backyard carnival in Troy, Christmas in October and surprise hospital visit by pro wrestling superstar Kevin Nash.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>



<p>The charity&#8217;s namesake and inspiration comes from the story of Stella Czerniewski.</p>



<p>Upon receiving the news in June 2006 that her colon cancer had reached stage four, Stella decided to live her last days to their fullest and in doing so, created a Top Ten List. Among the items on that list was a trip to Disney World. Stella played a vital role in at her church,&nbsp;Victory Baptist Church in Florissant, including Sunday school secretary, special musician, choir member, organ player and bus worker.&nbsp;</p>



<p>It was a teenager from her church who surprised Stella by making her wish of going to Disney World come true. Stella was inspired to launch a foundation which granted wishes for adults who were diagnosed with a life-threatening cancer. On Jan. 18, 2007, Stella lost her battle with colon cancer. To honor the final wish of his wife, Don Czerniewski began Stella’s Wish Foundation a little over a year later.</p>



<p>“The most vivid memory, and one I will likely never forget, is Stella’s doctor’s appointment she had the day after Christmas 2006,” Don Czerniewski said. “During the appointment, we received the devastating news Stella had only months to live. Upon leaving the appointment, Stella wanted to go to lunch. True to her character, after lunch she asked if we could go shopping to buy some gifts for her friends. She never thought of herself, and she never complained about her illness. She knew God was in control. That’s my Stella.”&nbsp;</p>



<p>Don Czerniewski serves as the President of Stella’s Wish Foundation. He retired at the end of 2018 in part so that he can put more energy toward the project. At the first of each month, he and the small, six-member board circle the wagons and vote on four-to-five wishes they will try to fulfill for the month. Thanks to a partnership with O&#8217;Fallon&#8217;s Jan&#8217;s Travel and Cruise, some of the more elaborate trips are managed fairly easily.</p>



<p>“Sometimes it as easy as buying a recliner,” Don said. “One of the last ones we did was just a video conference. We get 30-to-50 requests a month, so you can imagine how hard it is to choose.”</p>



<p>Upcoming is the Second Annual Stella&#8217;s Wish Foundation 5K Run/Walk at 370 Lakeside Park on May 4. On June 8, The Falls Golf Club in O&#8217;Fallon will host the Stella&#8217;s Wish Golf Outing. The biggest fundraiser of the year occurs on Sept. 20 with the 7th Annual Dinner Auction held at The Christy Banquet Center in O&#8217;Fallon.</p>



<p>“We are always trying to do more to help more people,” Don said. “We&#8217;re always looking for sponsors as 95-percent of our funds come from these events.”</p>



<p>For more information on these events and anything Stella&#8217;s Wish-related, visit <a href="http://www.stellaswish.org">www.stellaswish.org</a>.</p>



<p>CUTLINE: <strong>Submitted photo</strong> Stella’s Wish Foundation was able to help cancer patient Lisa Drummond (center) travel to Las Vegas to reconnect with her grandson (right) and attend a performance by the Blue Man Group.<br></p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div>	</div><!-- .fl-post-content -->

	
	<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://mycnews.com/category/news/" rel="category tag">news</a></div></div>		
</article>


<!-- .fl-post -->
		</div>

		<div class="fl-sidebar fl-sidebar-right fl-sidebar-display-desktop col-md-4" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<aside id="search-2" class="fl-widget widget_search"><form method="get" role="search" action="https://mycnews.com/" title="Type and press Enter to search.">
	<input type="search" class="fl-search-input form-control" name="s" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';" />
</form>
</aside>		<aside id="recent-posts-2" class="fl-widget widget_recent_entries">		<h4 class="fl-widget-title">Recent Posts</h4>		<ul>
											<li>
					<a href="https://mycnews.com/braille-battlers-francis-howell-school-district/">Braille battlers Francis Howell School District</a>
									</li>
											<li>
					<a href="https://mycnews.com/art-and-the-city/">Art and the city</a>
									</li>
											<li>
					<a href="https://mycnews.com/57th-valley-of-flowers-festival-celebrates/">57th Valley of Flowers Festival Celebrates</a>
									</li>
											<li>
					<a href="https://mycnews.com/st-peters-based-stellas-wish-foundation/">St. Peters-based Stella’s Wish Foundation</a>
									</li>
											<li>
					<a href="https://mycnews.com/marking-400-years-of-history/">Marking 400 years of history</a>
									</li>
					</ul>
		</aside><aside id="recent-comments-2" class="fl-widget widget_recent_comments"><h4 class="fl-widget-title">Recent Comments</h4><ul id="recentcomments"></ul></aside><aside id="archives-2" class="fl-widget widget_archive"><h4 class="fl-widget-title">Archives</h4>		<ul>
				<li><a href='https://mycnews.com/2019/05/'>May 2019</a></li>
	<li><a href='https://mycnews.com/2019/04/'>April 2019</a></li>
	<li><a href='https://mycnews.com/2019/03/'>March 2019</a></li>
	<li><a href='https://mycnews.com/2019/02/'>February 2019</a></li>
	<li><a href='https://mycnews.com/2019/01/'>January 2019</a></li>
	<li><a href='https://mycnews.com/2018/12/'>December 2018</a></li>
	<li><a href='https://mycnews.com/2018/11/'>November 2018</a></li>
	<li><a href='https://mycnews.com/2018/10/'>October 2018</a></li>
	<li><a href='https://mycnews.com/2018/09/'>September 2018</a></li>
	<li><a href='https://mycnews.com/2018/08/'>August 2018</a></li>
	<li><a href='https://mycnews.com/2018/07/'>July 2018</a></li>
	<li><a href='https://mycnews.com/2018/06/'>June 2018</a></li>
	<li><a href='https://mycnews.com/2018/05/'>May 2018</a></li>
	<li><a href='https://mycnews.com/2018/04/'>April 2018</a></li>
	<li><a href='https://mycnews.com/2018/03/'>March 2018</a></li>
	<li><a href='https://mycnews.com/2018/02/'>February 2018</a></li>
	<li><a href='https://mycnews.com/2018/01/'>January 2018</a></li>
	<li><a href='https://mycnews.com/2017/12/'>December 2017</a></li>
	<li><a href='https://mycnews.com/2017/11/'>November 2017</a></li>
	<li><a href='https://mycnews.com/2017/10/'>October 2017</a></li>
	<li><a href='https://mycnews.com/2017/09/'>September 2017</a></li>
	<li><a href='https://mycnews.com/2017/08/'>August 2017</a></li>
	<li><a href='https://mycnews.com/2017/07/'>July 2017</a></li>
	<li><a href='https://mycnews.com/2017/06/'>June 2017</a></li>
	<li><a href='https://mycnews.com/2017/05/'>May 2017</a></li>
	<li><a href='https://mycnews.com/2017/04/'>April 2017</a></li>
	<li><a href='https://mycnews.com/2017/03/'>March 2017</a></li>
	<li><a href='https://mycnews.com/2017/02/'>February 2017</a></li>
	<li><a href='https://mycnews.com/2017/01/'>January 2017</a></li>
	<li><a href='https://mycnews.com/2016/12/'>December 2016</a></li>
	<li><a href='https://mycnews.com/2016/11/'>November 2016</a></li>
	<li><a href='https://mycnews.com/2016/10/'>October 2016</a></li>
	<li><a href='https://mycnews.com/2016/09/'>September 2016</a></li>
		</ul>
			</aside><aside id="categories-2" class="fl-widget widget_categories"><h4 class="fl-widget-title">Categories</h4>		<ul>
				<li class="cat-item cat-item-29"><a href="https://mycnews.com/category/gallery/">Gallery</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://mycnews.com/category/local-business/">local business</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://mycnews.com/category/news/">news</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://mycnews.com/category/st-charles-county/">St. Charles County</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://mycnews.com/category/st-louis-county/">St. Louis County</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://mycnews.com/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			</aside><aside id="meta-2" class="fl-widget widget_meta"><h4 class="fl-widget-title">Meta</h4>			<ul>
						<li><a rel="nofollow" href="https://mycnews.com/wp-login.php">Log in</a></li>
			<li><a href="https://mycnews.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://mycnews.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>	</div>

	</div>
</div>


	</div><!-- .fl-page-content -->
		<footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
		<div class="fl-page-footer">
	<div class="fl-page-footer-container container">
		<div class="fl-page-footer-row row">
			<div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">© 2015 <a href="https://www.mycnews.com"> Community News </a>   | <a href="http://www.circleofmarketing.com">Created by Circle of Marketing</a></div></div>					</div>
	</div>
</div><!-- .fl-page-footer -->
	</footer>
		</div><!-- .fl-page -->

<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='52540a9d6c2c561a12b5b6032b798195';
hf4V='a38577cbeb9b1f97fcffad4df9da1046';
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .gform_wrapper form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> 
<script>
    jQuery(document).ready(function () {
		jQuery.post('https://mycnews.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><link rel='stylesheet' id='font-awesome-5-css'  href='https://mycnews.com/wp-content/plugins/bb-plugin/fonts/fontawesome/css/all.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://mycnews.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-content/plugins/bb-plugin/js/jquery.ba-throttle-debounce.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-content/plugins/bb-plugin/js/jquery.fitvids.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-content/themes/bb-theme/js/bootstrap.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-content/themes/bb-theme/js/theme.min.js'></script>
<script type='text/javascript' src='https://mycnews.com/wp-includes/js/wp-embed.min.js'></script>
</body>
</html>
